# CVE-2024-30471: Apache StreamPipes: Potential creation of multiple identical accounts

> An attacker can exploit a race condition during user registration to create multiple accounts with the same email, corrupting user management.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2024
- **Updated:** 13 Sep 2024
- **Also known as:** GHSA-2qph-v9p2-q2gv, PYSEC-2024-172

## What is CVE-2024-30471?

CVE-2024-30471 is a medium-severity vulnerability in Apache StreamPipes, published on 17 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Time-of-check Time-of-use (TOCTOU) Race Condition vulnerability in Apache StreamPipes in user self-registration.
This allows an attacker to potentially request the creation of multiple accounts with the same email address until the email address is registered, creating many identical users and corrupting StreamPipe's user management.
This issue affects Apache StreamPipes: through 0.93.0.

Users are recommended to upgrade to version 0.95.0, which fixes the issue.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2024-30471?

5 open source packages ship an affected version, including org.apache.streampipes:streampipes-parent and streampipes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.streampipes:streampipes-parent` | Maven | All versions | 0.95.0 |
| `org.apache.streampipes:streampipes-parent` | Maven | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |

Products: Apache Streampipes.

## How do I fix CVE-2024-30471?

Upgrade org.apache.streampipes:streampipes-parent to 0.95.0 or later.

## Is CVE-2024-30471 being exploited?

There is no known exploitation of CVE-2024-30471 in the wild and no public exploit code.

## Other vulnerabilities in Apache StreamPipes

- [CVE-2024-29868](https://insights.sbomify.com/CVE-2024-29868/): Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation (critical 9.1)
- [CVE-2023-31469](https://insights.sbomify.com/CVE-2023-31469/): Apache StreamPipes: Privilege escalation through non-admin user (high 8.8)
- [CVE-2025-47411](https://insights.sbomify.com/CVE-2025-47411/): Apache StreamPipes: Leverage of User ID for Privilege Escalation (high 8.1)
- [CVE-2024-31979](https://insights.sbomify.com/CVE-2024-31979/): Apache StreamPipes: Possibility of SSRF in pipeline element installation process (high 7.5)
- [CVE-2024-24778](https://insights.sbomify.com/CVE-2024-24778/): Apache StreamPipes: Resources Permission Escalation (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-30471 and fix it if it is affected.

What it is: CVE-2024-30471 is a medium-severity vulnerability in Apache StreamPipes, published on 17 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-30471 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.streampipes:streampipes-parent (Maven): affected all versions; fixed in 0.95.0
- org.apache.streampipes:streampipes-parent (Maven): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-30471/ (Markdown: https://insights.sbomify.com/CVE-2024-30471/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-30471
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-30471
- OSV: https://osv.dev/vulnerability/CVE-2024-30471

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-30471/
Summaries are generated and may contain mistakes; the official description above is the record.
