# CVE-2024-30564: @andrei-tatar/nora-firebase-common Prototype Pollution vulnerability

> A remote attacker can execute arbitrary code via a crafted script in the updateState parameter of the nora-firebase-common library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2024
- **Updated:** 22 Aug 2024
- **Also known as:** GHSA-jjff-q3q4-5hh8

## What is CVE-2024-30564?

CVE-2024-30564 is a critical code injection vulnerability in n/a, published on 18 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue inandrei-tatar nora-firebase-common between v.1.0.41 and v.1.12.2 allows a remote attacker to execute arbitrary code via a crafted script to the updateState parameter of the updateStateInternal method.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-30564?

2 open source packages ship an affected version, including @andrei-tatar/nora-firebase-common.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@andrei-tatar/nora-firebase-common` | npm | From 1.0.41 | 1.12.3 |
| `@andrei-tatar/nora-firebase-common` | npm | From 1.0.41 | 1.12.3 |

## How do I fix CVE-2024-30564?

Upgrade @andrei-tatar/nora-firebase-common to 1.12.3 or later.

## Is CVE-2024-30564 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-30564 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-30564 and fix it if it is affected.

What it is: CVE-2024-30564 is a critical code injection vulnerability in n/a, published on 18 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-30564 exists.

Affected packages and fixed versions:
- @andrei-tatar/nora-firebase-common (npm): affected from 1.0.41; fixed in 1.12.3
- @andrei-tatar/nora-firebase-common (npm): affected from 1.0.41; fixed in 1.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-30564/ (Markdown: https://insights.sbomify.com/CVE-2024-30564/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-30564
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-30564
- OSV: https://osv.dev/vulnerability/CVE-2024-30564

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-30564/
Summaries are generated and may contain mistakes; the official description above is the record.
