CVE-2024-3092 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

Attackers can inject malicious scripts via the diff viewer to perform arbitrary actions on behalf of victims in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-3092?

CVE-2024-3092 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 12 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 16.9 before 16.9.4, all versions starting from 16.10 before 16.10.2. A payload may lead to a Stored XSS while using the diff viewer, allowing attackers to perform arbitrary actions on behalf of victims.

Weakness: CWE-79

Which versions are affected by CVE-2024-3092?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.9.016.9.4, 16.10.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-3092?

Upgrade gitlab to a fixed version for your release line: 16.9.4 or 16.10.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-3092 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3092 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-3092, GHSA-qvg5-w5f4-rcwh, UBUNTU-CVE-2024-3092.

Is CVE-2024-3092 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free