# CVE-2024-3095: SSRF in Langchain Web Research Retriever in langchain-ai/langchain

> Attackers can exploit SSRF in Langchain's Web Research Retriever to access local services, read metadata, and potentially execute code.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:P/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-q25c-c977-4cmh, PYSEC-2026-1516

## What is CVE-2024-3095?

CVE-2024-3095 is a medium-severity server-side request forgery vulnerability in langchain-ai/langchain, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability exists in the Web Research Retriever component of langchain-ai/langchain version 0.1.5. The vulnerability arises because the Web Research Retriever does not restrict requests to remote internet addresses, allowing it to reach local addresses. This flaw enables attackers to execute port scans, access local services, and in some scenarios, read instance metadata from cloud environments. The vulnerability is particularly concerning as it can be exploited to abuse the Web Explorer server as a proxy for web attacks on third parties and interact with servers in the local network, including reading their response data. This could potentially lead to arbitrary code execution, depending on the nature of the local services. The vulnerability is limited to GET requests, as POST requests are not possible, but the impact on confidentiality, integrity, and availability is significant due to the potential for stolen credentials and state-changing interactions with internal APIs.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-3095?

3 open source packages ship an affected version, including langchain-community. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-community` | PyPI | All versions | 0.2.9 |
| `langchain-community` | PyPI | All versions | 0.2.9 |
| `langchain-community` | PyPI | All versions | 0.2.9 |

Products: Langchain Langchain.

## How do I fix CVE-2024-3095?

Upgrade langchain-community to 0.2.9 or later.

## Is CVE-2024-3095 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3095 exists.

## Other vulnerabilities in langchain-ai/langchain

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3095 and fix it if it is affected.

What it is: CVE-2024-3095 is a medium-severity server-side request forgery vulnerability in langchain-ai/langchain, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3095 exists.

Affected packages and fixed versions:
- langchain-community (PyPI): affected all versions; fixed in 0.2.9
- langchain-community (PyPI): affected all versions; fixed in 0.2.9
- langchain-community (PyPI): affected all versions; fixed in 0.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3095/ (Markdown: https://insights.sbomify.com/CVE-2024-3095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3095
- OSV: https://osv.dev/vulnerability/CVE-2024-3095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3095/
Summaries are generated and may contain mistakes; the official description above is the record.
