{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-3096 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.28, 8.2.18 or 8.3.5.","what":"CVE-2024-3096 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-3096 and fix it if it is affected.\n\nWhat it is: CVE-2024-3096 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-3096 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5\n- php (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5\n- php-min (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3096/ (Markdown: https://insights.sbomify.com/CVE-2024-3096/index.md)","id":"CVE-2024-3096","markdown":"https://insights.sbomify.com/CVE-2024-3096/index.md","name":"CVE-2024-3096","record":{"aliases":["AZL-40061","AZL-40068","BELL-CVE-2024-3096","BIT-libphp-2024-3096","BIT-php-2024-3096","BIT-php-min-2024-3096","CLEANSTART-2026-UW00601","CLSA-2024-1714066065","CLSA-2024-1714066325","DEBIAN-CVE-2024-3096","ECHO-6da0-0cab-b959","GHSA-h746-cjrr-wfmr","OESA-2024-1592","OESA-2024-1596","OESA-2024-1656","OESA-2024-1668","OESA-2024-1669","UBUNTU-CVE-2024-3096"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP core library","requires_auth":"none","summary":"Attackers can bypass authentication by providing a blank password if the stored hash begins with a null byte.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"php","vendor":"php"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In PHP  version 8.1.* before 8.1.28, 8.2.* before 8.2.18, 8.3.* before 8.3.5, if a password stored with password_hash() starts with a null byte (\\x00), testing a blank string as the password via password_verify() will incorrectly return true.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PHP function password_verify can erroneously return true when argument contains NUL","id":"CVE-2024-3096","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","php:php"],"type":"auth_bypass","year":"2024"},"n_packages":3,"n_references":4,"next":{"headline":"WordPress Gallery Plugin – NextGEN Gallery \u003c= 3.59 - Missing Authorization to Unauthenticated Information Disclosure","id":"CVE-2024-3097"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.28","8.2.18","8.3.5"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2024-3096"},{"ecosystem":"Bitnami","fixed":["8.1.28","8.2.18","8.3.5"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2024-3096"},{"ecosystem":"Bitnami","fixed":["8.1.28","8.2.18","8.3.5"],"introduced":["0","8.2.0","8.3.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2024-3096"}],"prev":{"headline":"SSRF in Langchain Web Research Retriever in langchain-ai/langchain","id":"CVE-2024-3095"},"products":["PHP"],"published":"2024-04-29","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["PHP Group"]},"summary":"Attackers can bypass authentication by providing a blank password if the stored hash begins with a null byte.","url":"https://insights.sbomify.com/CVE-2024-3096/"}