# CVE-2024-3096: PHP function password_verify can erroneously return true when argument contains NUL

> Attackers can bypass authentication by providing a blank password if the stored hash begins with a null byte.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2024
- **Updated:** 4 Nov 2025
- **Also known as:** AZL-40061, AZL-40068, BELL-CVE-2024-3096, BIT-libphp-2024-3096, BIT-php-2024-3096, BIT-php-min-2024-3096, CLEANSTART-2026-UW00601, CLSA-2024-1714066065, CLSA-2024-1714066325, DEBIAN-CVE-2024-3096, ECHO-6da0-0cab-b959, GHSA-h746-cjrr-wfmr, OESA-2024-1592, OESA-2024-1596, OESA-2024-1656, OESA-2024-1668, OESA-2024-1669, UBUNTU-CVE-2024-3096

## What is CVE-2024-3096?

CVE-2024-3096 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In PHP  version 8.1.* before 8.1.28, 8.2.* before 8.2.18, 8.3.* before 8.3.5, if a password stored with password_hash() starts with a null byte (\x00), testing a blank string as the password via password_verify() will incorrectly return true.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-3096?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.28, 8.2.18, 8.3.5 |
| `php` | Bitnami | All versions | 8.1.28, 8.2.18, 8.3.5 |
| `php-min` | Bitnami | All versions | 8.1.28, 8.2.18, 8.3.5 |

Products: Debian Debian Linux, Php Php.

## How do I fix CVE-2024-3096?

Upgrade libphp to a fixed version for your release line: 8.1.28, 8.2.18 or 8.3.5.

## Is CVE-2024-3096 being exploited?

There is no known exploitation of CVE-2024-3096 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3096 and fix it if it is affected.

What it is: CVE-2024-3096 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-3096 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5
- php (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5
- php-min (Bitnami): affected all versions; fixed in 8.1.28, 8.2.18, 8.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3096/ (Markdown: https://insights.sbomify.com/CVE-2024-3096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3096
- OSV: https://osv.dev/vulnerability/CVE-2024-3096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3096/
Summaries are generated and may contain mistakes; the official description above is the record.
