# CVE-2024-3098: Prompt Injection leading to Arbitrary Code Execution in run-llama/llama_index

> Attackers can execute arbitrary code via prompt injection in the safe_eval function of the llama_index library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-wvpx-g427-q9wc, PYSEC-2026-397

## What is CVE-2024-3098?

CVE-2024-3098 is a critical code injection vulnerability in run-llama/llama_index, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was identified in the `exec_utils` class of the `llama_index` package, specifically within the `safe_eval` function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-3098?

3 open source packages ship an affected version, including llama-index-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | All versions | 0.10.24 |
| `llama-index-core` | PyPI | All versions | 0.10.24 |
| `llama-index-core` | PyPI | All versions | 0.10.24 |

## How do I fix CVE-2024-3098?

Upgrade llama-index-core to 0.10.24 or later.

## Is CVE-2024-3098 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3098 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3098 and fix it if it is affected.

What it is: CVE-2024-3098 is a critical code injection vulnerability in run-llama/llama_index, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3098 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected all versions; fixed in 0.10.24
- llama-index-core (PyPI): affected all versions; fixed in 0.10.24
- llama-index-core (PyPI): affected all versions; fixed in 0.10.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3098/ (Markdown: https://insights.sbomify.com/CVE-2024-3098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3098
- OSV: https://osv.dev/vulnerability/CVE-2024-3098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3098/
Summaries are generated and may contain mistakes; the official description above is the record.
