# CVE-2024-3099: Denial of Service and Data Model Poisoning via URL Encoding in mlflow/mlflow

> Attackers can create duplicate model names via URL encoding, causing denial of service or data poisoning for authenticated users.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mlflow-2024-3099, GHSA-8f8q-q2j7-7j2m, PYSEC-2026-1645

## What is CVE-2024-3099?

CVE-2024-3099 is a medium-severity vulnerability in Lfprojects Mlflow, published on 6 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability in mlflow/mlflow version 2.11.1 allows attackers to create multiple models with the same name by exploiting URL encoding. This flaw can lead to Denial of Service (DoS) as an authenticated user might not be able to use the intended model, as it will open a different model each time. Additionally, an attacker can exploit this vulnerability to perform data model poisoning by creating a model with the same name, potentially causing an authenticated user to become a victim by using the poisoned model. The issue stems from inadequate validation of model names, allowing for the creation of models with URL-encoded names that are treated as distinct from their URL-decoded counterparts.

Weakness: CWE-475 (Undefined Behavior for Input to API)

## Which versions are affected by CVE-2024-3099?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | None |
| `mlflow` | PyPI | All versions | 2.11.3 |
| `mlflow` | PyPI | All versions | 2.11.3 |
| `mlflow` | PyPI | All versions | 2.11.3 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2024-3099?

Upgrade mlflow to 2.11.3 or later.

## Is CVE-2024-3099 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3099 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3099 and fix it if it is affected.

What it is: CVE-2024-3099 is a medium-severity vulnerability in Lfprojects Mlflow, published on 6 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3099 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; no fix listed
- mlflow (PyPI): affected all versions; fixed in 2.11.3
- mlflow (PyPI): affected all versions; fixed in 2.11.3
- mlflow (PyPI): affected all versions; fixed in 2.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3099/ (Markdown: https://insights.sbomify.com/CVE-2024-3099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3099
- OSV: https://osv.dev/vulnerability/CVE-2024-3099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3099/
Summaries are generated and may contain mistakes; the official description above is the record.
