CVE-2024-31111 WordPress Core < 6.5.5 - Cross Site Scripting (XSS) vulnerability
Attackers can inject malicious scripts into WordPress pages, potentially stealing user sessions or executing code in victim browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-31111?
CVE-2024-31111 is a medium-severity cross-site scripting vulnerability in Automattic WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Automattic WordPress allows Stored XSS.This issue affects WordPress: from 6.5 through 6.5.4, from 6.4 through 6.4.4, from 6.3 through 6.3.4, from 6.2 through 6.2.5, from 6.1 through 6.1.6, from 6.0 through 6.0.8, from 5.9 through 5.9.9.
Weakness: CWE-79
Which versions are affected by CVE-2024-31111?
2 open source packages ship an affected version, including wordpress and wordpress-multisite.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | From 5.9.0 | 5.9.10, 6.0.9, 6.1.7, 6.2.6, 6.3.5, 6.4.5, 6.5.5 |
wordpress-multisite Bitnami | From 5.9.0 | 5.9.10, 6.0.9, 6.1.7, 6.2.6, 6.3.5, 6.4.5, 6.5.5 |
How do I fix CVE-2024-31111?
Upgrade wordpress to a fixed version for your release line: 5.9.10, 6.0.9, 6.1.7 or 6.2.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-31111 being exploited?
There is no known exploitation of CVE-2024-31111 in the wild and no public exploit code.
Sources
Also known as BIT-wordpress-2024-31111, BIT-wordpress-multisite-2024-31111, DEBIAN-CVE-2024-31111, GHSA-99h6-m3cc-x9j3, UBUNTU-CVE-2024-31111.