{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2024-31111 in the wild and no public exploit code.","fix":"Upgrade wordpress to a fixed version for your release line: 5.9.10, 6.0.9, 6.1.7 or 6.2.6.","what":"CVE-2024-31111 is a medium-severity cross-site scripting vulnerability in Automattic WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-31111 and fix it if it is affected.\n\nWhat it is: CVE-2024-31111 is a medium-severity cross-site scripting vulnerability in Automattic WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-31111 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 5.9.0; fixed in 5.9.10, 6.0.9, 6.1.7, 6.2.6, 6.3.5, 6.4.5, 6.5.5\n- wordpress-multisite (Bitnami): affected from 5.9.0; fixed in 5.9.10, 6.0.9, 6.1.7, 6.2.6, 6.3.5, 6.4.5, 6.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31111/ (Markdown: https://insights.sbomify.com/CVE-2024-31111/index.md)","id":"CVE-2024-31111","markdown":"https://insights.sbomify.com/CVE-2024-31111/index.md","name":"CVE-2024-31111","record":{"aliases":["BIT-wordpress-2024-31111","BIT-wordpress-multisite-2024-31111","DEBIAN-CVE-2024-31111","GHSA-99h6-m3cc-x9j3","UBUNTU-CVE-2024-31111"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress core","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into WordPress pages, potentially stealing user sessions or executing code in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Automattic WordPress allows Stored XSS.This issue affects WordPress: from 6.5 through 6.5.4, from 6.4 through 6.4.4, from 6.3 through 6.3.4, from 6.2 through 6.2.5, from 6.1 through 6.1.6, from 6.0 through 6.0.8, from 5.9 through 5.9.9.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Core \u003c 6.5.5 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-31111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"WordPress Convert Post Types plugin \u003c= 1.4 - Reflected Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-31112"},"packages":[{"ecosystem":"Bitnami","fixed":["5.9.10","6.0.9","6.1.7","6.2.6","6.3.5","6.4.5","6.5.5"],"introduced":["5.9.0","6.0.0","6.1.0","6.2.0","6.3.0","6.4.0","6.5.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-31111"},{"ecosystem":"Bitnami","fixed":["5.9.10","6.0.9","6.1.7","6.2.6","6.3.5","6.4.5","6.5.5"],"introduced":["5.9.0","6.0.0","6.1.0","6.2.0","6.3.0","6.4.0","6.5.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-31111"}],"prev":{"headline":"WordPress Contact Form 7 Newsletter plugin \u003c= 2.2 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-31110"},"products":["WordPress"],"published":"2024-06-25","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Automattic"]},"summary":"Attackers can inject malicious scripts into WordPress pages, potentially stealing user sessions or executing code in victim browsers.","url":"https://insights.sbomify.com/CVE-2024-31111/"}