CVE-2024-31141 Apache Kafka Clients: Privilege escalation to filesystem read-access via automatic ConfigProvider
Attackers with untrusted configuration access can use ConfigProviders to read arbitrary files and environment variables, escalating privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-31141?
CVE-2024-31141 is a medium-severity vulnerability in Apache Kafka Clients, published on 19 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Files or Directories Accessible to External Parties, Improper Privilege Management vulnerability in Apache Kafka Clients.
Apache Kafka Clients accept configuration data for customizing behavior, and includes ConfigProvider plugins in order to manipulate these configurations. Apache Kafka also provides FileConfigProvider, DirectoryConfigProvider, and EnvVarConfigProvider implementations which include the ability to read from disk or environment variables. In applications where Apache Kafka Clients configurations can be specified by an untrusted party, attackers may use these ConfigProviders to read arbitrary contents of the disk and environment variables.
In particular, this flaw may be used in Apache Kafka Connect to escalate from REST API access to filesystem/environment access, which may be undesirable in certain environments, including SaaS products. This issue affects Apache Kafka Clients: from 2.3.0 through 3.5.2, 3.6.2, 3.7.0.
Users with affected applications are recommended to upgrade kafka-clients to version >=3.8.0, and set the JVM system property "org.apache.kafka.automatic.config.providers=none". Users of Kafka Connect with one of the listed ConfigProvider implementations specified in their worker config are also recommended to add appropriate "allowlist.pattern" and "allowed.paths" to restrict their operation to appropriate bounds.
For users of Kafka Clients or Kafka Connect in environments that trust users with disk and environment variable access, it is not recommended to set the system property. For users of the Kafka Broker, Kafka MirrorMaker 2.0, Kafka Streams, and Kafka command-line tools, it is not recommended to set the system property.
Which versions are affected by CVE-2024-31141?
2 open source packages ship an affected version, including org.apache.kafka:kafka-clients. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kafka:kafka-clients Maven | From 2.3.0 | 3.7.1 |
org.apache.kafka:kafka-clients Maven | From 2.3.0 | 3.7.1 |
Products include Apache Kafka.
How do I fix CVE-2024-31141?
Upgrade org.apache.kafka:kafka-clients to 3.7.1 or later.
Is CVE-2024-31141 being exploited?
There is no known exploitation of CVE-2024-31141 in the wild and no public exploit code.
Other vulnerabilities in Apache Kafka Clients
- CVE-2026-33557 Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication
- CVE-2025-27818 Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration
- CVE-2018-17196 Improper Input Validation in Apache Kafka
- CVE-2026-35554 Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition
- CVE-2025-27817 Apache Kafka Client: Arbitrary file read and SSRF vulnerability
Sources
Also known as ECHO-e4df-4158-934d, GHSA-2x2g-32r7-p4x8, MINI-m6j4-2w5m-gvf9, MINI-wx4r-mfr9-v5rm, ROOT-APP-MAVEN-CVE-2024-31141.