{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.kafka:kafka-clients. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-31141 in the wild and no public exploit code.","fix":"Upgrade org.apache.kafka:kafka-clients to 3.7.1 or later.","what":"CVE-2024-31141 is a medium-severity vulnerability in Apache Kafka Clients, published on 19 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-31141 and fix it if it is affected.\n\nWhat it is: CVE-2024-31141 is a medium-severity vulnerability in Apache Kafka Clients, published on 19 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-31141 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.kafka:kafka-clients (Maven): affected from 2.3.0; fixed in 3.7.1\n- org.apache.kafka:kafka-clients (Maven): affected from 2.3.0; fixed in 3.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31141/ (Markdown: https://insights.sbomify.com/CVE-2024-31141/index.md)","id":"CVE-2024-31141","markdown":"https://insights.sbomify.com/CVE-2024-31141/index.md","name":"CVE-2024-31141","record":{"aliases":["ECHO-e4df-4158-934d","GHSA-2x2g-32r7-p4x8","MINI-m6j4-2w5m-gvf9","MINI-wx4r-mfr9-v5rm","ROOT-APP-MAVEN-CVE-2024-31141"],"analysis":{"component_type":"library","fix_type":"configuration_change","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Kafka Clients","requires_auth":"low_privilege","summary":"Attackers with untrusted configuration access can use ConfigProviders to read arbitrary files and environment variables, escalating privileges.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"kafka","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-552","name":"Files or Directories Accessible to External Parties"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Files or Directories Accessible to External Parties, Improper Privilege Management vulnerability in Apache Kafka Clients.\n\nApache Kafka Clients accept configuration data for customizing behavior, and includes ConfigProvider plugins in order to manipulate these configurations. Apache Kafka also provides FileConfigProvider, DirectoryConfigProvider, and EnvVarConfigProvider implementations which include the ability to read from disk or environment variables.\nIn applications where Apache Kafka Clients configurations can be specified by an untrusted party, attackers may use these ConfigProviders to read arbitrary contents of the disk and environment variables.\n\nIn particular, this flaw may be used in Apache Kafka Connect to escalate from REST API access to filesystem/environment access, which may be undesirable in certain environments, including SaaS products.\nThis issue affects Apache Kafka Clients: from 2.3.0 through 3.5.2, 3.6.2, 3.7.0.\n\nUsers with affected applications are recommended to upgrade kafka-clients to version \u003e=3.8.0, and set the JVM system property \"org.apache.kafka.automatic.config.providers=none\".\nUsers of Kafka Connect with one of the listed ConfigProvider implementations specified in their worker config are also recommended to add appropriate \"allowlist.pattern\" and \"allowed.paths\" to restrict their operation to appropriate bounds.\n\nFor users of Kafka Clients or Kafka Connect in environments that trust users with disk and environment variable access, it is not recommended to set the system property.\nFor users of the Kafka Broker, Kafka MirrorMaker 2.0, Kafka Streams, and Kafka command-line tools, it is not recommended to set the system property.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Kafka Clients: Privilege escalation to filesystem read-access via automatic ConfigProvider","id":"CVE-2024-31141","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"x86: Incorrect logic for BTC/SRSO mitigations","id":"CVE-2024-31142"},"packages":[{"ecosystem":"Maven","fixed":["3.7.1"],"introduced":["2.3.0"],"last_affected":[],"package":"org.apache.kafka:kafka-clients","purl":null,"source":"GHSA-2x2g-32r7-p4x8"},{"ecosystem":"Maven","fixed":["3.7.1"],"introduced":["2.3.0"],"last_affected":[],"package":"org.apache.kafka:kafka-clients","purl":"pkg:maven/org.apache.kafka/kafka-clients","source":"GHSA-2x2g-32r7-p4x8"}],"prev":{"headline":"Path traversal in TeamCity","id":"CVE-2024-31140"},"products":["Apache Kafka Clients"],"published":"2024-11-19","related":[{"cvss_score":9.1,"headline":"Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication","id":"CVE-2026-33557","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8.8,"headline":"Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration","id":"CVE-2025-27818","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":8.8,"headline":"Improper Input Validation in Apache Kafka","id":"CVE-2018-17196","kev_date_added":null,"published":"2019-07-11"},{"cvss_score":8.7,"headline":"Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition","id":"CVE-2026-35554","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":7.5,"headline":"Apache Kafka Client: Arbitrary file read and SSRF vulnerability","id":"CVE-2025-27817","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration","id":"CVE-2025-27819","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers","id":"CVE-2022-34917","kev_date_added":null,"published":"2022-09-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-31","vendors":["Apache Software Foundation"]},"summary":"Attackers with untrusted configuration access can use ConfigProviders to read arbitrary files and environment variables, escalating privileges.","url":"https://insights.sbomify.com/CVE-2024-31141/"}