CVE-2024-3115 Exposure of Sensitive Information to an Unauthorized Actor in GitLab

Medium 4.3 Published Updated

Attackers can access issues and epics without an SSO session via Duo Chat, exposing sensitive information in GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3115?

CVE-2024-3115 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab EE affecting all versions starting from 16.0 prior to 16.11.5, starting from 17.0 prior to 17.0.3, and starting from 17.1 prior to 17.1.1, which allows an attacker to access issues and epics without having an SSO session using Duo Chat.

Weakness: CWE-862

Which versions are affected by CVE-2024-3115?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.0.016.11.5, 17.0.3, 17.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-3115?

Upgrade gitlab to a fixed version for your release line: 16.11.5, 17.0.3 or 17.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-3115 being exploited?

There is no known exploitation of CVE-2024-3115 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-3115, GHSA-73p8-f56m-692w.

Is CVE-2024-3115 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free