CVE-2024-3116 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4

High 7.4 Published Updated

Attackers can execute arbitrary code on the server via the validate binary path API in pgAdmin 4, compromising database integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3116?

CVE-2024-3116 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 4 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.

Weakness: CWE-77

Which versions are affected by CVE-2024-3116?

3 open source packages ship an affected version, including pgadmin4. It affects 2 products.

PackageAffectedFixed in
pgadmin4 PyPIAll versions8.5
pgadmin4 PyPIAll versions8.5
pgadmin4 PyPIAll versions8.5

Products include Fedoraproject Fedora, Pgadmin Pgadmin 4.

How do I fix CVE-2024-3116?

Upgrade pgadmin4 to 8.5 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2024-3116 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3116 exists.

Public exploit code: 1 Metasploit module and 1 proofs of concept on GitHub.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as GHSA-27jx-ffw8-xrqv, PYSEC-2026-1767.

Is CVE-2024-3116 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free