{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3116 exists.","fix":"Upgrade pgadmin4 to 8.5 or later.","what":"CVE-2024-3116 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 4 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-3116 and fix it if it is affected.\n\nWhat it is: CVE-2024-3116 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 4 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3116 exists.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 8.5\n- pgadmin4 (PyPI): affected all versions; fixed in 8.5\n- pgadmin4 (PyPI): affected all versions; fixed in 8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-3116/ (Markdown: https://insights.sbomify.com/CVE-2024-3116/index.md)","id":"CVE-2024-3116","markdown":"https://insights.sbomify.com/CVE-2024-3116/index.md","name":"CVE-2024-3116","record":{"aliases":["GHSA-27jx-ffw8-xrqv","PYSEC-2026-1767"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL management tool","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code on the server via the validate binary path API in pgAdmin 4, compromising database integrity.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"pgAdmin \u003c= 8.4 is affected by a  Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2024-03-28","github_poc":1,"max_poc_stars":13,"metasploit":1,"nuclei":0,"refs":[{"date":"2024-04-07T23:03:55Z","kind":"github_poc","ref":"https://github.com/TechieNeurons/CVE-2024-3116_RCE_in_pgadmin_8.4","stars":13,"title":"Making a lab and testing the CVE-2024-3116, a Remote Code Execution in pgadmin \u003c=8.4"},{"date":"2024-03-28","kind":"metasploit","ref":"exploit/windows/http/pgadmin_binary_path_api","stars":null,"title":"pgAdmin Binary Path API RCE"}],"tier":"weaponised"},"has_fix":true,"headline":"Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4","id":"CVE-2024-3116","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"command_injection","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"YouDianCMS ChannelAction.class.php unrestricted upload","id":"CVE-2024-3117"},"packages":[{"ecosystem":"PyPI","fixed":["8.5"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-27jx-ffw8-xrqv"},{"ecosystem":"PyPI","fixed":["8.5"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-27jx-ffw8-xrqv"},{"ecosystem":"PyPI","fixed":["8.5"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-1767"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in GitLab","id":"CVE-2024-3115"},"products":["pgAdmin 4"],"published":"2024-04-04","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-14","vendors":["pgadmin.org"]},"summary":"Attackers can execute arbitrary code on the server via the validate binary path API in pgAdmin 4, compromising database integrity.","url":"https://insights.sbomify.com/CVE-2024-3116/"}