# CVE-2024-3116: Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4

> Attackers can execute arbitrary code on the server via the validate binary path API in pgAdmin 4, compromising database integrity.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2024
- **Updated:** 14 Mar 2025
- **Also known as:** GHSA-27jx-ffw8-xrqv, PYSEC-2026-1767

## What is CVE-2024-3116?

CVE-2024-3116 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 4 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pgAdmin <= 8.4 is affected by a  Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-3116?

3 open source packages ship an affected version, including pgadmin4. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 8.5 |
| `pgadmin4` | PyPI | All versions | 8.5 |
| `pgadmin4` | PyPI | All versions | 8.5 |

Products: Fedoraproject Fedora, Pgadmin Pgadmin 4.

## How do I fix CVE-2024-3116?

Upgrade pgadmin4 to 8.5 or later.

## Is CVE-2024-3116 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3116 exists.

Public exploit code:

- Making a lab and testing the CVE-2024-3116, a Remote Code Execution in pgadmin <=8.4 (github_poc): https://github.com/TechieNeurons/CVE-2024-3116_RCE_in_pgadmin_8.4
- pgAdmin Binary Path API RCE (metasploit)

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3116 and fix it if it is affected.

What it is: CVE-2024-3116 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 4 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3116 exists.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 8.5
- pgadmin4 (PyPI): affected all versions; fixed in 8.5
- pgadmin4 (PyPI): affected all versions; fixed in 8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3116/ (Markdown: https://insights.sbomify.com/CVE-2024-3116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3116
- OSV: https://osv.dev/vulnerability/CVE-2024-3116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3116/
Summaries are generated and may contain mistakes; the official description above is the record.
