{"answers":{"affected":"2 open source packages ship an affected version, including dectalk-tts.","exploited":"There is no known exploitation of CVE-2024-31206 in the wild and no public exploit code.","fix":"Upgrade dectalk-tts to 1.0.1 or later.","what":"CVE-2024-31206 is a high-severity vulnerability in JstnMcBrd dectalk-tts, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-31206 and fix it if it is affected.\n\nWhat it is: CVE-2024-31206 is a high-severity vulnerability in JstnMcBrd dectalk-tts, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-31206 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dectalk-tts (npm): affected from 1.0.0; fixed in 1.0.1\n- dectalk-tts (npm): affected from 1.0.0; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31206/ (Markdown: https://insights.sbomify.com/CVE-2024-31206/index.md)","id":"CVE-2024-31206","markdown":"https://insights.sbomify.com/CVE-2024-31206/index.md","name":"CVE-2024-31206","record":{"aliases":["GHSA-6cf6-8hvr-r68w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js TTS library","requires_auth":"none","summary":"Attackers can intercept and modify unencrypted HTTP traffic in the dectalk-tts library, enabling man-in-the-middle attacks against users.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-598","name":"Use of HTTP Request With Sensitive Query String"},{"id":"CWE-319","name":"Cleartext Transmission of Sensitive Information"},{"id":"CWE-300","name":"Channel Accessible by Non-Endpoint"}],"description":"dectalk-tts is a Node package to interact with the aeiou Dectalk web API. In `dectalk-tts@1.0.0`, network requests to the third-party API are sent over HTTP, which is unencrypted. Unencrypted traffic can be easily intercepted and modified by attackers. Anyone who uses the package could be the victim of a man-in-the-middle (MITM) attack. The network request was upgraded to HTTPS in version `1.0.1`. There are no workarounds, but some precautions include not sending any sensitive information and carefully verifying the API response before saving it.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use of Unencrypted HTTP Request in dectalk-tts","id":"CVE-2024-31206","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"Vite's `server.fs.deny` did not deny requests for patterns with directories","id":"CVE-2024-31207"},"packages":[{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"dectalk-tts","purl":null,"source":"GHSA-6cf6-8hvr-r68w"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["1.0.0"],"last_affected":[],"package":"dectalk-tts","purl":"pkg:npm/dectalk-tts","source":"GHSA-6cf6-8hvr-r68w"}],"prev":{"headline":"Saleor CSRF bypass in refreshToken mutation","id":"CVE-2024-31205"},"products":["dectalk-tts"],"published":"2024-04-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-26","vendors":["JstnMcBrd"]},"summary":"Attackers can intercept and modify unencrypted HTTP traffic in the dectalk-tts library, enabling man-in-the-middle attacks against users.","url":"https://insights.sbomify.com/CVE-2024-31206/"}