# CVE-2024-31206: Use of Unencrypted HTTP Request in dectalk-tts

> Attackers can intercept and modify unencrypted HTTP traffic in the dectalk-tts library, enabling man-in-the-middle attacks against users.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2024
- **Updated:** 26 Aug 2024
- **Also known as:** GHSA-6cf6-8hvr-r68w

## What is CVE-2024-31206?

CVE-2024-31206 is a high-severity vulnerability in JstnMcBrd dectalk-tts, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dectalk-tts is a Node package to interact with the aeiou Dectalk web API. In `dectalk-tts@1.0.0`, network requests to the third-party API are sent over HTTP, which is unencrypted. Unencrypted traffic can be easily intercepted and modified by attackers. Anyone who uses the package could be the victim of a man-in-the-middle (MITM) attack. The network request was upgraded to HTTPS in version `1.0.1`. There are no workarounds, but some precautions include not sending any sensitive information and carefully verifying the API response before saving it.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String), CWE-319 (Cleartext Transmission of Sensitive Information), CWE-300 (Channel Accessible by Non-Endpoint)

## Which versions are affected by CVE-2024-31206?

2 open source packages ship an affected version, including dectalk-tts.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dectalk-tts` | npm | From 1.0.0 | 1.0.1 |
| `dectalk-tts` | npm | From 1.0.0 | 1.0.1 |

## How do I fix CVE-2024-31206?

Upgrade dectalk-tts to 1.0.1 or later.

## Is CVE-2024-31206 being exploited?

There is no known exploitation of CVE-2024-31206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31206 and fix it if it is affected.

What it is: CVE-2024-31206 is a high-severity vulnerability in JstnMcBrd dectalk-tts, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31206 in the wild and no public exploit code.

Affected packages and fixed versions:
- dectalk-tts (npm): affected from 1.0.0; fixed in 1.0.1
- dectalk-tts (npm): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31206/ (Markdown: https://insights.sbomify.com/CVE-2024-31206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31206
- OSV: https://osv.dev/vulnerability/CVE-2024-31206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31206/
Summaries are generated and may contain mistakes; the official description above is the record.
