CVE-2024-31208 Synapse's V2 state resolution weakness allows DoS from remote room members

Medium 6.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-31208?

CVE-2024-31208 is a medium-severity vulnerability in Fedoraproject Fedora, published on 23 Apr 2024.

Official description

Synapse is an open-source Matrix homeserver. A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in the V2 state resolution algorithm. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service. Servers in private federations, or those that do not federate, are not affected. Server administrators should upgrade to 1.105.1 or later. Some workarounds are available. One can ban the malicious users or ACL block servers from the rooms and/or leave the room and purge the room using the admin API.

Weakness: CWE-770

Which versions are affected by CVE-2024-31208?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.

PackageAffectedFixed in
matrix-synapse PyPIAll versions1.105.1
matrix-synapse PyPIAll versions1.105.1
matrix-synapse PyPIAll versions1.105.1
Linux distribution packages (1)
matrix-synapse openSUSE:TumbleweedAll versions1.105.1-1.1

Products include Fedoraproject Fedora, Matrix Synapse.

How do I fix CVE-2024-31208?

Upgrade matrix-synapse to 1.105.1 or later.

Is CVE-2024-31208 being exploited?

There is no known exploitation of CVE-2024-31208 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as GHSA-3h7q-rfh9-xm4v, PYSEC-2024-50, UBUNTU-CVE-2024-31208, openSUSE-SU-2024:13897-1.

Is CVE-2024-31208 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free