# CVE-2024-31208: Synapse's V2 state resolution weakness allows DoS from remote room members


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Apr 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-3h7q-rfh9-xm4v, PYSEC-2024-50, UBUNTU-CVE-2024-31208, openSUSE-SU-2024:13897-1

## What is CVE-2024-31208?

CVE-2024-31208 is a medium-severity vulnerability in Fedoraproject Fedora, published on 23 Apr 2024. 

### Official description

Synapse is an open-source Matrix homeserver. A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in the V2 state resolution algorithm. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service. Servers in private federations, or those that do not federate, are not affected. Server administrators should upgrade to 1.105.1 or later. Some workarounds are available. One can ban the malicious users or ACL block servers from the rooms and/or leave the room and purge the room using the admin API.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-31208?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.105.1 |
| `matrix-synapse` | PyPI | All versions | 1.105.1 |
| `matrix-synapse` | PyPI | All versions | 1.105.1 |
| `matrix-synapse` | openSUSE:Tumbleweed | All versions | 1.105.1-1.1 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2024-31208?

Upgrade matrix-synapse to 1.105.1 or later.

## Is CVE-2024-31208 being exploited?

There is no known exploitation of CVE-2024-31208 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31208 and fix it if it is affected.

What it is: CVE-2024-31208 is a medium-severity vulnerability in Fedoraproject Fedora, published on 23 Apr 2024. 
Exploitation: There is no known exploitation of CVE-2024-31208 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.105.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.105.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.105.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31208/ (Markdown: https://insights.sbomify.com/CVE-2024-31208/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31208
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31208
- OSV: https://osv.dev/vulnerability/CVE-2024-31208

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31208/
Summaries are generated and may contain mistakes; the official description above is the record.
