CVE-2024-31211 Remote Code Execution in `WP_HTML_Token`

Medium 5.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-31211?

CVE-2024-31211 is a medium-severity vulnerability in Wordpress Wordpress, published on 4 Apr 2024.

Official description

WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.

Weakness: CWE-502

Which versions are affected by CVE-2024-31211?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.

PackageAffectedFixed in
wordpress BitnamiFrom 6.4.06.4.2
wordpress-multisite BitnamiFrom 6.4.06.4.2

Products include Wordpress Wordpress.

How do I fix CVE-2024-31211?

Upgrade wordpress to 6.4.2 or later.

Is CVE-2024-31211 being exploited?

There is no known exploitation of CVE-2024-31211 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Wordpress Wordpress vulnerabilities

Sources

Also known as BIT-wordpress-2024-31211, BIT-wordpress-multisite-2024-31211, DEBIAN-CVE-2024-31211, GHSA-m257-q4m5-j653, UBUNTU-CVE-2024-31211.

Is CVE-2024-31211 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free