{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-31211 in the wild and no public exploit code.","fix":"Upgrade wordpress to 6.4.2 or later.","what":"CVE-2024-31211 is a medium-severity vulnerability in Wordpress Wordpress, published on 4 Apr 2024."},"fix_prompt":"Check this codebase for CVE-2024-31211 and fix it if it is affected.\n\nWhat it is: CVE-2024-31211 is a medium-severity vulnerability in Wordpress Wordpress, published on 4 Apr 2024. \nExploitation: There is no known exploitation of CVE-2024-31211 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 6.4.0; fixed in 6.4.2\n- wordpress-multisite (Bitnami): affected from 6.4.0; fixed in 6.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31211/ (Markdown: https://insights.sbomify.com/CVE-2024-31211/index.md)","id":"CVE-2024-31211","markdown":"https://insights.sbomify.com/CVE-2024-31211/index.md","name":"CVE-2024-31211","record":{"aliases":["BIT-wordpress-2024-31211","BIT-wordpress-multisite-2024-31211","DEBIAN-CVE-2024-31211","GHSA-m257-q4m5-j653","UBUNTU-CVE-2024-31211"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2024-08-03","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-08-03T19:26:55Z","kind":"github_poc","ref":"https://github.com/Abdurahmon3236/-CVE-2024-31211","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Remote Code Execution in `WP_HTML_Token`","id":"CVE-2024-31211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"wordpress:wordpress","products":["wordpress:wordpress"],"type":null,"year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"SQL injection in index_chart_data action","id":"CVE-2024-31212"},"packages":[{"ecosystem":"Bitnami","fixed":["6.4.2"],"introduced":["6.4.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-31211"},{"ecosystem":"Bitnami","fixed":["6.4.2"],"introduced":["6.4.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-31211"}],"prev":{"headline":"PHP file upload bypass via Plugin installer","id":"CVE-2024-31210"},"products":["wordpress-develop"],"published":"2024-04-04","related":[{"cvss_score":9.8,"headline":"WordPress Core Interpretation Conflict","id":"CVE-2026-63030","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":8.1,"headline":"WordPress Core Remote File Inclusion","id":"CVE-2026-87902","kev_date_added":"2026-09-25","published":"2026-09-22"},{"cvss_score":5.9,"headline":"WordPress Core SQL Injection","id":"CVE-2026-60137","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2012-2399","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2012-2400","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3122","kev_date_added":null,"published":"2011-08-10"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3125","kev_date_added":null,"published":"2011-08-10"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["WordPress"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-31211/"}