# CVE-2024-31211: Remote Code Execution in `WP_HTML_Token`


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-wordpress-2024-31211, BIT-wordpress-multisite-2024-31211, DEBIAN-CVE-2024-31211, GHSA-m257-q4m5-j653, UBUNTU-CVE-2024-31211

## What is CVE-2024-31211?

CVE-2024-31211 is a medium-severity vulnerability in Wordpress Wordpress, published on 4 Apr 2024. 

### Official description

WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-31211?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 6.4.0 | 6.4.2 |
| `wordpress-multisite` | Bitnami | From 6.4.0 | 6.4.2 |

Products: Wordpress Wordpress.

## How do I fix CVE-2024-31211?

Upgrade wordpress to 6.4.2 or later.

## Is CVE-2024-31211 being exploited?

There is no known exploitation of CVE-2024-31211 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Abdurahmon3236/-CVE-2024-31211 (github_poc): https://github.com/Abdurahmon3236/-CVE-2024-31211

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31211 and fix it if it is affected.

What it is: CVE-2024-31211 is a medium-severity vulnerability in Wordpress Wordpress, published on 4 Apr 2024. 
Exploitation: There is no known exploitation of CVE-2024-31211 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 6.4.0; fixed in 6.4.2
- wordpress-multisite (Bitnami): affected from 6.4.0; fixed in 6.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31211/ (Markdown: https://insights.sbomify.com/CVE-2024-31211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31211
- OSV: https://osv.dev/vulnerability/CVE-2024-31211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31211/
Summaries are generated and may contain mistakes; the official description above is the record.
