# CVE-2024-31215: Mobile Security Framework (MobSF) vulnerable to Server-Side Request Forgery (SSRF) in firebase database check

> Attacker can force MobSF server to access internal services via SSRF in Firebase check, potentially exposing internal infrastructure data.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-wpff-wm84-x5cx, PYSEC-2026-1676

## What is CVE-2024-31215?

CVE-2024-31215 is a medium-severity server-side request forgery vulnerability in Mobile-Security-Framework-MobSF, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mobile Security Framework (MobSF) is a security research platform for mobile applications in Android, iOS and Windows Mobile.
A SSRF vulnerability in firebase database check logic. The attacker can cause the server to make a connection to internal-only services within the organization’s infrastructure. When a malicious app is uploaded to Static analyzer, it is possible to make internal requests. This vulnerability has been patched in version 3.9.8.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-31215?

3 open source packages ship an affected version, including mobsf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mobsf` | PyPI | All versions | 3.9.8 |
| `mobsf` | PyPI | All versions | 3.9.8 |
| `mobsf` | PyPI | All versions | 3.9.8 |

Products: Opensecurity Mobile Security Framework.

## How do I fix CVE-2024-31215?

Upgrade mobsf to 3.9.8 or later.

## Is CVE-2024-31215 being exploited?

There is no known exploitation of CVE-2024-31215 in the wild and no public exploit code.

## Other vulnerabilities in Mobile-Security-Framework-MobSF

- [CVE-2025-46335](https://insights.sbomify.com/CVE-2025-46335/): Mobile Security Framework (MobSF) Allows Stored Cross Site Scripting (XSS) via malicious SVG Icon Upload (high 8.6)
- [CVE-2025-24805](https://insights.sbomify.com/CVE-2025-24805/): Local Privilege Escalation in MobSF (high 8.5)
- [CVE-2025-24803](https://insights.sbomify.com/CVE-2025-24803/): Stored Cross-Site Scripting (XSS) in MobSF (high 8.4)
- [CVE-2026-24490](https://insights.sbomify.com/CVE-2026-24490/): MobSF has Stored XSS via Manifest Analysis - Dialer Code Host Field (high 8.1)
- [CVE-2024-53999](https://insights.sbomify.com/CVE-2024-53999/): Mobile Security Framework (MobSF) Stored Cross-Site Scripting Vulnerability in "Diff or Compare" Functionality (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31215 and fix it if it is affected.

What it is: CVE-2024-31215 is a medium-severity server-side request forgery vulnerability in Mobile-Security-Framework-MobSF, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-31215 in the wild and no public exploit code.

Affected packages and fixed versions:
- mobsf (PyPI): affected all versions; fixed in 3.9.8
- mobsf (PyPI): affected all versions; fixed in 3.9.8
- mobsf (PyPI): affected all versions; fixed in 3.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31215/ (Markdown: https://insights.sbomify.com/CVE-2024-31215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31215
- OSV: https://osv.dev/vulnerability/CVE-2024-31215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31215/
Summaries are generated and may contain mistakes; the official description above is the record.
