# CVE-2024-31216: source-controller leaks theAzure Storage SAS token into logs on connection errors

> Attackers with log access can steal Azure SAS tokens leaked during connection errors, gaining unauthorized access to Azure Blob Storage.

- **Severity:** Medium 5.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-v554-xwgw-hc3w, GO-2024-2859

## What is CVE-2024-31216?

CVE-2024-31216 is a medium-severity vulnerability in fluxcd source-controller, published on 15 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The source-controller is a Kubernetes operator, specialised in artifacts acquisition from external sources such as Git, OCI, Helm repositories and S3-compatible buckets. The source-controller implements the source.toolkit.fluxcd.io API and is a core component of the GitOps toolkit. Prior to version 1.2.5, when source-controller was configured to use an Azure SAS token when connecting to Azure Blob Storage, the token was logged along with the Azure URL when the controller encountered a connection error. An attacker with access to the source-controller logs could use the token to gain access to the Azure Blob Storage until the token expires. This vulnerability was fixed in source-controller v1.2.5. There is no workaround for this vulnerability except for using a different auth mechanism such as Azure Workload Identity.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-31216?

3 open source packages ship an affected version, including github.com/fluxcd/source-controller.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fluxcd/source-controller` | Go | All versions | 1.2.5 |
| `github.com/fluxcd/source-controller` | Go | All versions | 1.2.5 |
| `github.com/fluxcd/source-controller` | Go | All versions | 1.2.5 |

## How do I fix CVE-2024-31216?

Upgrade github.com/fluxcd/source-controller to 1.2.5 or later.

## Is CVE-2024-31216 being exploited?

There is no known exploitation of CVE-2024-31216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31216 and fix it if it is affected.

What it is: CVE-2024-31216 is a medium-severity vulnerability in fluxcd source-controller, published on 15 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31216 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fluxcd/source-controller (Go): affected all versions; fixed in 1.2.5
- github.com/fluxcd/source-controller (Go): affected all versions; fixed in 1.2.5
- github.com/fluxcd/source-controller (Go): affected all versions; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31216/ (Markdown: https://insights.sbomify.com/CVE-2024-31216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31216
- OSV: https://osv.dev/vulnerability/CVE-2024-31216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31216/
Summaries are generated and may contain mistakes; the official description above is the record.
