# CVE-2024-31223: Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL

> Unauthenticated attackers can disclose server-side configuration details like private IPs and domains via the Privacy Center.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-53q7-4874-24qg, PYSEC-2026-1334

## What is CVE-2024-31223?

CVE-2024-31223 is a medium-severity vulnerability in ethyca fides, published on 3 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform, and `SERVER_SIDE_FIDES_API_URL` is a server-side configuration environment variable used by the Fides Privacy Center to communicate with the Fides webserver backend. The value of this variable is a URL which typically includes a private IP address, private domain name, and/or port. A vulnerability present starting in version 2.19.0 and prior to version 2.39.2rc0 allows an unauthenticated attacker to make a HTTP GET request from the Privacy Center that discloses the value of this server-side URL. This could result in disclosure of server-side configuration giving an attacker information on server-side ports, private IP addresses, and/or private domain names. The vulnerability has been patched in Fides version 2.39.2rc0. No known workarounds are available.

Weakness: CWE-497 (Exposure of Sensitive System Information to an Unauthorized Control Sphere)

## Which versions are affected by CVE-2024-31223?

3 open source packages ship an affected version, including ethyca-fides. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | From 2.19.0 | 2.39.2 |
| `ethyca-fides` | PyPI | From 2.19.0 | 2.39.2 |
| `ethyca-fides` | PyPI | From 2.19.0 | 2.39.2 |

Products: Ethyca Fides.

## How do I fix CVE-2024-31223?

Upgrade ethyca-fides to 2.39.2 or later.

## Is CVE-2024-31223 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31223 exists.

Public exploit code:

- Fides Privacy Center ≤ 2.39.1 - Server-Side URL Disclosure (nuclei): http/cves/2024/CVE-2024-31223.yaml

## Other vulnerabilities in ethyca fides

- [CVE-2024-45053](https://insights.sbomify.com/CVE-2024-45053/): Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine (critical 9.1)
- [CVE-2023-41319](https://insights.sbomify.com/CVE-2023-41319/): Remote Code Execution in Custom Integration Upload in Fides (high 8.8)
- [CVE-2025-57817](https://insights.sbomify.com/CVE-2025-57817/): Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation (high 8.6)
- [CVE-2023-48224](https://insights.sbomify.com/CVE-2023-48224/): Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides (high 8.2)
- [CVE-2023-46124](https://insights.sbomify.com/CVE-2023-46124/): Server-Side Request Forgery Vulnerability in Custom Integration Upload (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31223 and fix it if it is affected.

What it is: CVE-2024-31223 is a medium-severity vulnerability in ethyca fides, published on 3 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31223 exists.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.39.2
- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.39.2
- ethyca-fides (PyPI): affected from 2.19.0; fixed in 2.39.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31223/ (Markdown: https://insights.sbomify.com/CVE-2024-31223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31223
- OSV: https://osv.dev/vulnerability/CVE-2024-31223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31223/
Summaries are generated and may contain mistakes; the official description above is the record.
