CVE-2024-31227 Denial-of-service due to malformed ACL selectors in Redis

Medium 4.4 Published Updated

An authenticated user with sufficient privileges can cause a server panic and denial of service by creating a malformed ACL selector in Redis.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-31227?

CVE-2024-31227 is a medium-severity denial of service vulnerability in redis, published on 7 Oct 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem exists in Redis 7 prior to versions 7.2.6 and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-20

Which versions are affected by CVE-2024-31227?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.

PackageAffectedFixed in
redis BitnamiFrom 7.0.07.2.8, 7.4.1
keydb BitnamiFrom 7.0.0None
valkey BitnamiAll versions7.2.7, 8.0.1

Products include Redis Redis.

How do I fix CVE-2024-31227?

Upgrade redis to a fixed version for your release line: 7.2.8 or 7.4.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-31227 being exploited?

There is no known exploitation of CVE-2024-31227 in the wild and no public exploit code.

Sources

Also known as ALPINE-CVE-2024-31227, AZL-52008, BELL-CVE-2024-31227, BIT-keydb-2024-31227, BIT-redis-2024-31227, BIT-valkey-2024-31227 and 5 more.

Is CVE-2024-31227 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free