CVE-2024-3127 Improper Access Control in GitLab

Medium 4.3 Published Updated

Attackers can bypass IP restrictions via GraphQL to perform unauthorized group-level actions in GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3127?

CVE-2024-3127 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 22 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab EE affecting all versions starting from 12.5 before 17.1.6, all versions starting from 17.2 before 17.2.4, all versions starting from 17.3 before 17.3.1. Under certain conditions it may be possible to bypass the IP restriction for groups through GraphQL allowing unauthorised users to perform some actions at the group level.

Weakness: CWE-863, CWE-284

Which versions are affected by CVE-2024-3127?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.5.017.1.6, 17.2.4, 17.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-3127?

Upgrade gitlab to a fixed version for your release line: 17.1.6, 17.2.4 or 17.3.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-3127 being exploited?

There is no known exploitation of CVE-2024-3127 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-3127, GHSA-9c64-9pw3-wh7p, UBUNTU-CVE-2024-3127.

Is CVE-2024-3127 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free