# CVE-2024-31391: Apache Solr Operator: Solr-Operator liveness and readiness probes may leak basic auth credentials

> An attacker with access to Kubernetes events can read basic auth credentials leaked by Solr Operator probes when authentication is enabled on health checks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Apr 2024
- **Updated:** 13 Mar 2025
- **Also known as:** GHSA-g9qx-25vj-rf53, GO-2024-2723

## What is CVE-2024-31391?

CVE-2024-31391 is a medium-severity vulnerability in Apache Solr Operator, published on 12 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insertion of Sensitive Information into Log File vulnerability in the Apache Solr Operator.

This issue affects all versions of the Apache Solr Operator from 0.3.0 through 0.8.0.

When asked to bootstrap Solr security, the operator will enable basic authentication and create several accounts for accessing Solr: including the "solr" and "admin" accounts for use by end-users, and a "k8s-oper" account which the operator uses for its own requests to Solr.
One common source of these operator requests is healthchecks: liveness, readiness, and startup probes are all used to determine Solr's health and ability to receive traffic.
By default, the operator configures the Solr APIs used for these probes to be exempt from authentication, but users may specifically request that authentication be required on probe endpoints as well.
Whenever one of these probes would fail, if authentication was in use, the Solr Operator would create a Kubernetes "event" containing the username and password of the "k8s-oper" account.

Within the affected version range, this vulnerability affects any solrcloud resource which (1) bootstrapped security through use of the `.solrOptions.security.authenticationType=basic` option, and (2) required authentication be used on probes by setting `.solrOptions.security.probesRequireAuth=true`.

Users are recommended to upgrade to Solr Operator version 0.8.1, which fixes this issue by ensuring that probes no longer print the credentials used for Solr requests.  Users may also mitigate the vulnerability by disabling authentication on their healthcheck probes using the setting `.solrOptions.security.probesRequireAuth=false`.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-31391?

3 open source packages ship an affected version, including github.com/apache/solr-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/apache/solr-operator` | Go | From 0.3.0 | 0.8.1 |
| `github.com/apache/solr-operator` | Go | From 0.3.0 | 0.8.1 |
| `github.com/apache/solr-operator` | Go | From 0.3.0 | 0.8.1 |

Products: Apache Solr Operator.

## How do I fix CVE-2024-31391?

Upgrade github.com/apache/solr-operator to 0.8.1 or later.

## Is CVE-2024-31391 being exploited?

There is no known exploitation of CVE-2024-31391 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31391 and fix it if it is affected.

What it is: CVE-2024-31391 is a medium-severity vulnerability in Apache Solr Operator, published on 12 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31391 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/apache/solr-operator (Go): affected from 0.3.0; fixed in 0.8.1
- github.com/apache/solr-operator (Go): affected from 0.3.0; fixed in 0.8.1
- github.com/apache/solr-operator (Go): affected from 0.3.0; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31391/ (Markdown: https://insights.sbomify.com/CVE-2024-31391/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31391
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31391
- OSV: https://osv.dev/vulnerability/CVE-2024-31391

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31391/
Summaries are generated and may contain mistakes; the official description above is the record.
