CVE-2024-31411 Apache StreamPipes: Potential remote code execution (RCE) via file upload

Medium 6.0 Published Updated

Authenticated attackers can upload dangerous files to achieve remote code execution in Apache StreamPipes.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-31411?

CVE-2024-31411 is a medium-severity vulnerability in Apache StreamPipes, published on 17 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Unrestricted Upload of File with dangerous type vulnerability in Apache StreamPipes. Such a dangerous type might be an executable file that may lead to a remote code execution (RCE). The unrestricted upload is only possible for authenticated and authorized users. This issue affects Apache StreamPipes: through 0.93.0.

Users are recommended to upgrade to version 0.95.0, which fixes the issue.

Weakness: CWE-434

Which versions are affected by CVE-2024-31411?

5 open source packages ship an affected version, including org.apache.streampipes:streampipes-parent and streampipes. It affects 1 product.

PackageAffectedFixed in
org.apache.streampipes:streampipes-parent MavenAll versions0.95.0
org.apache.streampipes:streampipes-parent MavenAll versions0.95.0
streampipes PyPIAll versions0.95.0
streampipes PyPIAll versions0.95.0
streampipes PyPIAll versions0.95.0

Products include Apache Streampipes.

How do I fix CVE-2024-31411?

Upgrade org.apache.streampipes:streampipes-parent to 0.95.0 or later.

Is CVE-2024-31411 being exploited?

There is no known exploitation of CVE-2024-31411 in the wild and no public exploit code.

Sources

Also known as GHSA-6523-jf4r-c962, PYSEC-2024-173.

Is CVE-2024-31411 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free