# CVE-2024-31411: Apache StreamPipes: Potential remote code execution (RCE) via file upload

> Authenticated attackers can upload dangerous files to achieve remote code execution in Apache StreamPipes.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2024
- **Updated:** 13 Sep 2024
- **Also known as:** GHSA-6523-jf4r-c962, PYSEC-2024-173

## What is CVE-2024-31411?

CVE-2024-31411 is a medium-severity vulnerability in Apache StreamPipes, published on 17 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Unrestricted Upload of File with dangerous type vulnerability in Apache StreamPipes.
Such a dangerous type might be an executable file that may lead to a remote code execution (RCE).
The unrestricted upload is only possible for authenticated and authorized users.
This issue affects Apache StreamPipes: through 0.93.0.

Users are recommended to upgrade to version 0.95.0, which fixes the issue.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2024-31411?

5 open source packages ship an affected version, including org.apache.streampipes:streampipes-parent and streampipes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.streampipes:streampipes-parent` | Maven | All versions | 0.95.0 |
| `org.apache.streampipes:streampipes-parent` | Maven | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |
| `streampipes` | PyPI | All versions | 0.95.0 |

Products: Apache Streampipes.

## How do I fix CVE-2024-31411?

Upgrade org.apache.streampipes:streampipes-parent to 0.95.0 or later.

## Is CVE-2024-31411 being exploited?

There is no known exploitation of CVE-2024-31411 in the wild and no public exploit code.

## Other vulnerabilities in Apache StreamPipes

- [CVE-2024-29868](https://insights.sbomify.com/CVE-2024-29868/): Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation (critical 9.1)
- [CVE-2023-31469](https://insights.sbomify.com/CVE-2023-31469/): Apache StreamPipes: Privilege escalation through non-admin user (high 8.8)
- [CVE-2025-47411](https://insights.sbomify.com/CVE-2025-47411/): Apache StreamPipes: Leverage of User ID for Privilege Escalation (high 8.1)
- [CVE-2024-31979](https://insights.sbomify.com/CVE-2024-31979/): Apache StreamPipes: Possibility of SSRF in pipeline element installation process (high 7.5)
- [CVE-2024-24778](https://insights.sbomify.com/CVE-2024-24778/): Apache StreamPipes: Resources Permission Escalation (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31411 and fix it if it is affected.

What it is: CVE-2024-31411 is a medium-severity vulnerability in Apache StreamPipes, published on 17 Jul 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31411 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.streampipes:streampipes-parent (Maven): affected all versions; fixed in 0.95.0
- org.apache.streampipes:streampipes-parent (Maven): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0
- streampipes (PyPI): affected all versions; fixed in 0.95.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31411/ (Markdown: https://insights.sbomify.com/CVE-2024-31411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31411
- OSV: https://osv.dev/vulnerability/CVE-2024-31411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31411/
Summaries are generated and may contain mistakes; the official description above is the record.
