# CVE-2024-31447: Shopware has Improper Session Handling in store-api

> Attackers can maintain active sessions after logout via store-api, bypassing authentication controls in Shopware 6.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Apr 2024
- **Updated:** 3 Sep 2024
- **Also known as:** GHSA-5297-wrrp-rcj7

## What is CVE-2024-31447?

CVE-2024-31447 is a medium-severity authentication bypass vulnerability in Shopware Shopware, published on 8 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Starting in version 6.3.5.0 and prior to versions 6.6.1.0 and 6.5.8.8, when a authenticated request is made to `POST /store-api/account/logout`, the cart will be cleared, but the User won't be logged out. This affects only the direct store-api usage, as the PHP Storefront listens additionally on `CustomerLogoutEvent` and invalidates the session additionally. The problem has been fixed in Shopware 6.6.1.0 and 6.5.8.8. Those who are unable to update can install the latest version of the Shopware Security Plugin as a workaround.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2024-31447?

8 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | From 6.3.5.0 | 6.5.8.8 |
| `shopware/core` | Packagist | From 6.3.5.0 | 6.5.8.8 |
| `shopware/core` | Packagist | From 6.6.0.0-rc1 | 6.6.1.0 |
| `shopware/core` | Packagist | From 6.6.0.0-rc1 | 6.6.1.0 |
| `shopware/platform` | Packagist | From 6.3.5.0 | 6.5.8.8 |
| `shopware/platform` | Packagist | From 6.3.5.0 | 6.5.8.8 |
| `shopware/platform` | Packagist | From 6.6.0.0-rc1 | 6.6.1.0 |
| `shopware/platform` | Packagist | From 6.6.0.0-rc1 | 6.6.1.0 |

Products: Shopware Shopware.

## How do I fix CVE-2024-31447?

Upgrade shopware/core to a fixed version for your release line: 6.5.8.8 or 6.6.1.0.

## Is CVE-2024-31447 being exploited?

There is no known exploitation of CVE-2024-31447 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31447 and fix it if it is affected.

What it is: CVE-2024-31447 is a medium-severity authentication bypass vulnerability in Shopware Shopware, published on 8 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-31447 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected from 6.3.5.0; fixed in 6.5.8.8
- shopware/core (Packagist): affected from 6.3.5.0; fixed in 6.5.8.8
- shopware/core (Packagist): affected from 6.6.0.0-rc1; fixed in 6.6.1.0
- shopware/core (Packagist): affected from 6.6.0.0-rc1; fixed in 6.6.1.0
- shopware/platform (Packagist): affected from 6.3.5.0; fixed in 6.5.8.8
- shopware/platform (Packagist): affected from 6.3.5.0; fixed in 6.5.8.8
- shopware/platform (Packagist): affected from 6.6.0.0-rc1; fixed in 6.6.1.0
- shopware/platform (Packagist): affected from 6.6.0.0-rc1; fixed in 6.6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31447/ (Markdown: https://insights.sbomify.com/CVE-2024-31447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31447
- OSV: https://osv.dev/vulnerability/CVE-2024-31447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31447/
Summaries are generated and may contain mistakes; the official description above is the record.
