{"answers":{"affected":"3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-31452 in the wild and no public exploit code.","fix":"Upgrade github.com/openfga/openfga to 1.5.3 or later.","what":"CVE-2024-31452 is a high-severity authentication bypass vulnerability in openfga, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-31452 and fix it if it is affected.\n\nWhat it is: CVE-2024-31452 is a high-severity authentication bypass vulnerability in openfga, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-31452 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/openfga/openfga (Go): affected from 1.5.0; fixed in 1.5.3\n- github.com/openfga/openfga (Go): affected from 1.5.0; fixed in 1.5.3\n- github.com/openfga/openfga (Go): affected from 1.5.0; fixed in 1.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31452/ (Markdown: https://insights.sbomify.com/CVE-2024-31452/index.md)","id":"CVE-2024-31452","markdown":"https://insights.sbomify.com/CVE-2024-31452/index.md","name":"CVE-2024-31452","record":{"aliases":["GHSA-8cph-m685-6v6r","GO-2024-2729"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenFGA authorization engine","requires_auth":"none","summary":"Attackers can bypass authorization checks in OpenFGA when using exclusion or intersection logic in permission models.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openfga","vendor":"openfga"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"OpenFGA is a high-performance and flexible authorization/permission engine. Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs. You are very likely affected if your model involves exclusion (e.g. `a but not b`) or intersection (e.g. `a and b`). This vulnerability is fixed in v1.5.3.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenFGA Authorization Bypass","id":"CVE-2024-31452","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"PsiTransfer vulnerable to violation of the integrity of file distribution","id":"CVE-2024-31453"},"packages":[{"ecosystem":"Go","fixed":["1.5.3"],"introduced":["1.5.0"],"last_affected":[],"package":"github.com/openfga/openfga","purl":null,"source":"GHSA-8cph-m685-6v6r"},{"ecosystem":"Go","fixed":["1.5.3"],"introduced":["1.5.0"],"last_affected":[],"package":"github.com/openfga/openfga","purl":"pkg:golang/github.com/openfga/openfga","source":"GHSA-8cph-m685-6v6r"},{"ecosystem":"Go","fixed":["1.5.3"],"introduced":["1.5.0"],"last_affected":[],"package":"github.com/openfga/openfga","purl":"pkg:golang/github.com/openfga/openfga","source":"GO-2024-2729"}],"prev":{"headline":"Limited file write in routes.py (GHSL-2023-250)","id":"CVE-2024-31451"},"products":["openfga"],"published":"2024-04-16","related":[{"cvss_score":7.7,"headline":"OpenFGA Authorization Bypass","id":"CVE-2022-23542","kev_date_added":null,"published":"2022-12-20"},{"cvss_score":7.5,"headline":"OpenFGA Authorization Bypass","id":"CVE-2024-42473","kev_date_added":null,"published":"2024-08-09"},{"cvss_score":6.5,"headline":"OpenFGA Playground Preshared Key Exposure","id":"CVE-2026-40293","kev_date_added":null,"published":"2026-04-17"},{"cvss_score":6.5,"headline":"OpenFGA Authorization Bypass","id":"CVE-2023-40579","kev_date_added":null,"published":"2023-08-25"},{"cvss_score":5.9,"headline":"Denial of service from circular relationship definitions in OpenFGA","id":"CVE-2023-43645","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":5.9,"headline":"OpenFGA denial of service die to circular relationship","id":"CVE-2023-35933","kev_date_added":null,"published":"2023-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["openfga"]},"summary":"Attackers can bypass authorization checks in OpenFGA when using exclusion or intersection logic in permission models.","url":"https://insights.sbomify.com/CVE-2024-31452/"}