{"answers":{"affected":"2 open source packages ship an affected version, including psitransfer.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31454 exists.","fix":"Upgrade psitransfer to 2.2.0 or later.","what":"CVE-2024-31454 is a medium-severity vulnerability in psi-4ward psitransfer, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-31454 and fix it if it is affected.\n\nWhat it is: CVE-2024-31454 is a medium-severity vulnerability in psi-4ward psitransfer, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31454 exists.\n\nAffected packages and fixed versions:\n- psitransfer (npm): affected all versions; fixed in 2.2.0\n- psitransfer (npm): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31454/ (Markdown: https://insights.sbomify.com/CVE-2024-31454/index.md)","id":"CVE-2024-31454","markdown":"https://insights.sbomify.com/CVE-2024-31454/index.md","name":"CVE-2024-31454","record":{"aliases":["GHSA-2p2x-p7wj-j5h2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PsiTransfer file sharing","requires_auth":"none","summary":"Attackers can modify uploaded files in shared distributions, potentially delivering malicious content to subsequent users.","user_interaction":"required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"PsiTransfer is an open source, self-hosted file sharing solution. Prior to version 2.2.0, the absence of restrictions on the endpoint, which is designed for uploading files, allows an attacker who received the id of a file distribution to change the files that are in this distribution. The vulnerability allows an attacker to influence those users who come to the file distribution after them and slip the victim files with a malicious or phishing signature. Version 2.2.0 contains a patch for this issue.\n\nCVE-2024-31454 allows users to violate the integrity of a file that is uploaded by another user. In this case, additional files are not loaded into the file bucket. Violation of integrity at the level of individual files. While the vulnerability with the number CVE-2024-31453 allows users to violate the integrity of a file bucket without violating the integrity of files uploaded by other users. Thus, vulnerabilities are reproduced differently, require different security recommendations and affect different objects of the application’s business logic.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PsiTransfer file integrity violation vulnerability","id":"CVE-2024-31454","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"file_upload","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Minder GetRepositoryByName data leak","id":"CVE-2024-31455"},"packages":[{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"psitransfer","purl":null,"source":"GHSA-2p2x-p7wj-j5h2"},{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"psitransfer","purl":"pkg:npm/psitransfer","source":"GHSA-2p2x-p7wj-j5h2"}],"prev":{"headline":"PsiTransfer vulnerable to violation of the integrity of file distribution","id":"CVE-2024-31453"},"products":["psitransfer"],"published":"2024-04-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-04","vendors":["psi-4ward"]},"summary":"Attackers can modify uploaded files in shared distributions, potentially delivering malicious content to subsequent users.","url":"https://insights.sbomify.com/CVE-2024-31454/"}