# CVE-2024-31454: PsiTransfer file integrity violation vulnerability

> Attackers can modify uploaded files in shared distributions, potentially delivering malicious content to subsequent users.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2024
- **Updated:** 4 Sep 2024
- **Also known as:** GHSA-2p2x-p7wj-j5h2

## What is CVE-2024-31454?

CVE-2024-31454 is a medium-severity vulnerability in psi-4ward psitransfer, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PsiTransfer is an open source, self-hosted file sharing solution. Prior to version 2.2.0, the absence of restrictions on the endpoint, which is designed for uploading files, allows an attacker who received the id of a file distribution to change the files that are in this distribution. The vulnerability allows an attacker to influence those users who come to the file distribution after them and slip the victim files with a malicious or phishing signature. Version 2.2.0 contains a patch for this issue.

CVE-2024-31454 allows users to violate the integrity of a file that is uploaded by another user. In this case, additional files are not loaded into the file bucket. Violation of integrity at the level of individual files. While the vulnerability with the number CVE-2024-31453 allows users to violate the integrity of a file bucket without violating the integrity of files uploaded by other users. Thus, vulnerabilities are reproduced differently, require different security recommendations and affect different objects of the application’s business logic.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2024-31454?

2 open source packages ship an affected version, including psitransfer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `psitransfer` | npm | All versions | 2.2.0 |
| `psitransfer` | npm | All versions | 2.2.0 |

## How do I fix CVE-2024-31454?

Upgrade psitransfer to 2.2.0 or later.

## Is CVE-2024-31454 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31454 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31454 and fix it if it is affected.

What it is: CVE-2024-31454 is a medium-severity vulnerability in psi-4ward psitransfer, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31454 exists.

Affected packages and fixed versions:
- psitransfer (npm): affected all versions; fixed in 2.2.0
- psitransfer (npm): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31454/ (Markdown: https://insights.sbomify.com/CVE-2024-31454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31454
- OSV: https://osv.dev/vulnerability/CVE-2024-31454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31454/
Summaries are generated and may contain mistakes; the official description above is the record.
