CVE-2024-31464 XWiki Platform: Password hash might be leaked by diff once the xobject holding them is deleted
Attackers with edit rights can leak password hashes via the history diff feature when password objects are deleted, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-31464?
CVE-2024-31464 is a medium-severity vulnerability in Xwiki Xwiki, published on 10 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in version 5.0-rc-1 and prior to versions 14.10.19, 15.5.4, and 15.9-rc-1, it is possible to access the hash of a password by using the diff feature of the history whenever the object storing the password is deleted. Using that vulnerability it's possible for an attacker to have access to the hash password of a user if they have rights to edit the users' page. With the default right scheme in XWiki this vulnerability is normally prevented on user profiles, except by users with Admin rights. Note that this vulnerability also impacts any extensions that might use passwords stored in xobjects: for those usecases it depends on the right of those pages. There is currently no way to be 100% sure that this vulnerability has been exploited, as an attacker with enough privilege could have deleted the revision where the xobject was deleted after rolling-back the deletion. But again, this operation requires high privileges on the target page (Admin right). A page with a user password xobject which have in its history a revision where the object has been deleted should be considered at risk and the password should be changed there. a diff, to ensure it's not coming from a password field. As another mitigation, admins should ensure that the user pages are properly protected: the edit right shouldn't be allowed for other users than Admin and owner of the profile (which is the default right). There is not much workaround possible for a privileged user other than upgrading XWiki.
Which versions are affected by CVE-2024-31464?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.6-rc-1 | 15.9-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.6-rc-1 | 15.9-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 5.0-rc-1 | 14.10.19 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 5.0-rc-1 | 14.10.19 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-31464?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.5.4, 15.9-rc-1 or 14.10.19.
Is CVE-2024-31464 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31464 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-v782-xr4w-3vqx.