CVE-2024-31465 XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet
Authenticated users with edit rights can execute arbitrary code on the server by adding a specific object to their profile or pages.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-31465?
CVE-2024-31465 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform. Starting in version 5.0-rc-1 and prior to versions 14.10.20, 15.5.4, and 15.9-rc-1, any user with edit right on any page can execute any code on the server by adding an object of type `XWiki.SearchSuggestSourceClass` to their user profile or any other page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability has been patched in XWiki 14.10.20, 15.5.4 and 15.10 RC1. As a workaround, manually apply the patch to the document `XWiki.SearchSuggestSourceSheet`.
Which versions are affected by CVE-2024-31465?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-search-ui Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 15.0-rc-1 | 15.5.4 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 15.6-rc-1 | 15.10-rc-1 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 15.6-rc-1 | 15.10-rc-1 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 5.2-milestone-2 | 14.10.20 |
org.xwiki.platform:xwiki-platform-search-ui Maven | From 5.2-milestone-2 | 14.10.20 |
Products include Xwiki Xwiki.
How do I fix CVE-2024-31465?
Upgrade org.xwiki.platform:xwiki-platform-search-ui to a fixed version for your release line: 15.5.4, 15.10-rc-1 or 14.10.20.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2024-31465 being exploited?
There is no known exploitation of CVE-2024-31465 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-34fj-r5gq-7395.