# CVE-2024-31465: XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet

> Authenticated users with edit rights can execute arbitrary code on the server by adding a specific object to their profile or pages.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2024
- **Updated:** 13 Aug 2024
- **Also known as:** GHSA-34fj-r5gq-7395

## What is CVE-2024-31465?

CVE-2024-31465 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform. Starting in version 5.0-rc-1 and prior to versions 14.10.20, 15.5.4, and 15.9-rc-1, any user with edit right on any page can execute any code on the server by adding an object of type `XWiki.SearchSuggestSourceClass` to their user profile or any other page. This compromises the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability has been patched in XWiki 14.10.20, 15.5.4 and 15.10 RC1. As a workaround, manually apply the patch to the document `XWiki.SearchSuggestSourceSheet`.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2024-31465?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-search-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-search-ui` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.platform:xwiki-platform-search-ui` | Maven | From 15.0-rc-1 | 15.5.4 |
| `org.xwiki.platform:xwiki-platform-search-ui` | Maven | From 15.6-rc-1 | 15.10-rc-1 |
| `org.xwiki.platform:xwiki-platform-search-ui` | Maven | From 15.6-rc-1 | 15.10-rc-1 |
| `org.xwiki.platform:xwiki-platform-search-ui` | Maven | From 5.2-milestone-2 | 14.10.20 |
| `org.xwiki.platform:xwiki-platform-search-ui` | Maven | From 5.2-milestone-2 | 14.10.20 |

Products: Xwiki Xwiki.

## How do I fix CVE-2024-31465?

Upgrade org.xwiki.platform:xwiki-platform-search-ui to a fixed version for your release line: 15.5.4, 15.10-rc-1 or 14.10.20.

## Is CVE-2024-31465 being exploited?

There is no known exploitation of CVE-2024-31465 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31465 and fix it if it is affected.

What it is: CVE-2024-31465 is a critical code injection vulnerability in Xwiki Xwiki, published on 10 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-31465 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-search-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.platform:xwiki-platform-search-ui (Maven): affected from 15.0-rc-1; fixed in 15.5.4
- org.xwiki.platform:xwiki-platform-search-ui (Maven): affected from 15.6-rc-1; fixed in 15.10-rc-1
- org.xwiki.platform:xwiki-platform-search-ui (Maven): affected from 15.6-rc-1; fixed in 15.10-rc-1
- org.xwiki.platform:xwiki-platform-search-ui (Maven): affected from 5.2-milestone-2; fixed in 14.10.20
- org.xwiki.platform:xwiki-platform-search-ui (Maven): affected from 5.2-milestone-2; fixed in 14.10.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31465/ (Markdown: https://insights.sbomify.com/CVE-2024-31465/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31465
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31465
- OSV: https://osv.dev/vulnerability/CVE-2024-31465

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31465/
Summaries are generated and may contain mistakes; the official description above is the record.
