# CVE-2024-31503: Dolibarr vulnerable to Cross-Site Request Forgery

> Authenticated attackers can steal session cookies and CSRF tokens via crafted pages, leading to account takeover in Dolibarr ERP CRM.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 19 Aug 2024
- **Also known as:** BIT-dolibarr-2024-31503, GHSA-6ppg-rgrg-f573, UBUNTU-CVE-2024-31503

## What is CVE-2024-31503?

CVE-2024-31503 is a high-severity vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 16 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Incorrect access control in Dolibarr ERP CRM versions 19.0.0 and before, allows authenticated attackers to steal victim users' session cookies and CSRF protection tokens via user interaction with a crafted web page, leading to account takeover.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-31503?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions to 19.0.0 | None |
| `dolibarr/dolibarr` | Packagist | All versions to 19.0.0 | None |
| `dolibarr` | Bitnami | All versions | 19.0.1 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2024-31503?

Upgrade to a fixed version.

## Is CVE-2024-31503 being exploited?

There is no known exploitation of CVE-2024-31503 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31503 and fix it if it is affected.

What it is: CVE-2024-31503 is a high-severity vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 16 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-31503 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions up to 19.0.0; no fix listed
- dolibarr/dolibarr (Packagist): affected all versions up to 19.0.0; no fix listed
- dolibarr (Bitnami): affected all versions; fixed in 19.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31503/ (Markdown: https://insights.sbomify.com/CVE-2024-31503/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31503
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31503
- OSV: https://osv.dev/vulnerability/CVE-2024-31503

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31503/
Summaries are generated and may contain mistakes; the official description above is the record.
