{"answers":{"affected":"2 open source packages ship an affected version, including org.xmlunit:xmlunit-core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31573 exists.","fix":"Upgrade org.xmlunit:xmlunit-core to 2.10.0 or later.","what":"CVE-2024-31573 is a medium-severity code injection vulnerability in XMLUnit for Java, published on 17 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-31573 and fix it if it is affected.\n\nWhat it is: CVE-2024-31573 is a medium-severity code injection vulnerability in XMLUnit for Java, published on 17 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31573 exists.\n\nAffected packages and fixed versions:\n- org.xmlunit:xmlunit-core (Maven): affected all versions; fixed in 2.10.0\n- org.xmlunit:xmlunit-core (Maven): affected all versions; fixed in 2.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31573/ (Markdown: https://insights.sbomify.com/CVE-2024-31573/index.md)","id":"CVE-2024-31573","markdown":"https://insights.sbomify.com/CVE-2024-31573/index.md","name":"CVE-2024-31573","record":{"aliases":["CLEANSTART-2026-UV31886","CLSA-2024-1727136010","CLSA-2025-1740614445","CLSA-2026-1793128026","GHSA-chfm-68vv-pvw5","OESA-2025-1966","OESA-2025-1967","OESA-2025-1968","OESA-2025-1969","OESA-2025-1970","RHLW-2026-bf51d193d76de6ef","RHLW-2026-de2bb03e40c2ec86","RHLW-2026-e5adae5b227184e1","RHLW-2026-ea9f6fe6976a39aa","ROOT-APP-MAVEN-CVE-2024-31573","UBUNTU-CVE-2024-31573"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java XML testing library","requires_auth":"none","summary":"Attackers can execute arbitrary code via untrusted XSLT stylesheets in XMLUnit for Java due to enabled extension functions.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-669","name":"Incorrect Resource Transfer Between Spheres"}],"description":"XMLUnit for Java before 2.10.0, in the default configuration, might allow code execution via an untrusted stylesheet (used for an XSLT transformation), because XSLT extension functions are enabled.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"XMLUnit for Java has Insecure Defaults when Processing XSLT Stylesheets","id":"CVE-2024-31573","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-31574"},"packages":[{"ecosystem":"Maven","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"org.xmlunit:xmlunit-core","purl":null,"source":"GHSA-chfm-68vv-pvw5"},{"ecosystem":"Maven","fixed":["2.10.0"],"introduced":["0"],"last_affected":[],"package":"org.xmlunit:xmlunit-core","purl":"pkg:maven/org.xmlunit/xmlunit-core","source":"GHSA-chfm-68vv-pvw5"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2024-31570"},"products":["XMLUnit for Java"],"published":"2025-10-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-17","vendors":["XMLUnit"]},"summary":"Attackers can execute arbitrary code via untrusted XSLT stylesheets in XMLUnit for Java due to enabled extension functions.","url":"https://insights.sbomify.com/CVE-2024-31573/"}