{"answers":{"affected":"5 open source packages ship an affected version, including torch, pytorch and torch-npu. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-31580 in the wild and no public exploit code.","fix":"Upgrade torch to 2.2.0 or later.","what":"CVE-2024-31580 is a medium-severity memory corruption vulnerability in n/a, published on 17 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-31580 and fix it if it is affected.\n\nWhat it is: CVE-2024-31580 is a medium-severity memory corruption vulnerability in n/a, published on 17 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-31580 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- torch (PyPI): affected all versions; fixed in 2.2.0\n- torch (PyPI): affected all versions; fixed in 2.2.0\n- torch (PyPI): affected all versions; fixed in 2.2.0\n- pytorch (Bitnami): affected all versions; fixed in 2.2.1\n- torch-npu (PyPI): affected all versions; fixed in 2.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31580/ (Markdown: https://insights.sbomify.com/CVE-2024-31580/index.md)","id":"CVE-2024-31580","markdown":"https://insights.sbomify.com/CVE-2024-31580/index.md","name":"CVE-2024-31580","record":{"aliases":["AZL-39930","BIT-pytorch-2024-31580","DEBIAN-CVE-2024-31580","GHSA-5pcm-hx3q-hm94","PYSEC-2024-252","PYSEC-2024-328","UBUNTU-CVE-2024-31580"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PyTorch machine learning library","requires_auth":"none","summary":"Attackers can cause a Denial of Service in PyTorch via a heap buffer overflow triggered by crafted input.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pytorch","vendor":"linuxfoundation"}],"cvss":{"score":4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PyTorch heap buffer overflow vulnerability","id":"CVE-2024-31580","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":5,"n_references":2,"next":{"headline":"Integer overflow in n/a","id":"CVE-2024-31581"},"packages":[{"ecosystem":"Bitnami","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"pytorch","purl":"pkg:bitnami/pytorch","source":"BIT-pytorch-2024-31580"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"torch","purl":null,"source":"GHSA-5pcm-hx3q-hm94"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"torch","purl":"pkg:pypi/torch","source":"GHSA-5pcm-hx3q-hm94"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"torch","purl":"pkg:pypi/torch","source":"PYSEC-2024-252"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"torch-npu","purl":"pkg:pypi/torch-npu","source":"PYSEC-2024-328"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2024-31578"},"products":["n/a"],"published":"2024-04-17","related":[{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2024-48063","kev_date_added":null,"published":"2024-10-29"},{"cvss_score":9.8,"headline":"PyTorch vulnerable to arbitrary code execution","id":"CVE-2022-45907","kev_date_added":null,"published":"2022-11-26"},{"cvss_score":9.3,"headline":"PyTorch: `torch.load` with `weights_only=True` leads to remote code execution","id":"CVE-2025-32434","kev_date_added":null,"published":"2025-04-18"},{"cvss_score":8.8,"headline":"PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files","id":"CVE-2026-24747","kev_date_added":null,"published":"2026-01-27"},{"cvss_score":7.8,"headline":"Pytorch use-after-free vulnerability","id":"CVE-2024-31583","kev_date_added":null,"published":"2024-04-17"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2025-55551","kev_date_added":null,"published":"2025-09-25"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2025-55553","kev_date_added":null,"published":"2025-09-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-28","vendors":["n/a"]},"summary":"Attackers can cause a Denial of Service in PyTorch via a heap buffer overflow triggered by crafted input.","url":"https://insights.sbomify.com/CVE-2024-31580/"}