{"answers":{"affected":"4 open source packages ship an affected version, including torch and pytorch. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-31583 in the wild and no public exploit code.","fix":"Upgrade torch to 2.2.0 or later.","what":"CVE-2024-31583 is a high-severity use after free vulnerability in n/a, published on 17 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-31583 and fix it if it is affected.\n\nWhat it is: CVE-2024-31583 is a high-severity use after free vulnerability in n/a, published on 17 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-31583 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- torch (PyPI): affected all versions; fixed in 2.2.0\n- torch (PyPI): affected all versions; fixed in 2.2.0\n- torch (PyPI): affected all versions; fixed in 2.2.0\n- pytorch (Bitnami): affected all versions; fixed in 2.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31583/ (Markdown: https://insights.sbomify.com/CVE-2024-31583/index.md)","id":"CVE-2024-31583","markdown":"https://insights.sbomify.com/CVE-2024-31583/index.md","name":"CVE-2024-31583","record":{"aliases":["AZL-39942","BIT-pytorch-2024-31583","DEBIAN-CVE-2024-31583","GHSA-pg7h-5qx3-wjr3","PYSEC-2024-251","UBUNTU-CVE-2024-31583"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PyTorch machine learning library","requires_auth":"none","summary":"A use-after-free flaw in PyTorch's mobile interpreter allows attackers to potentially execute arbitrary code or cause a denial of service.","user_interaction":"required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pytorch","vendor":"linuxfoundation"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Pytorch before version v2.2.0 was discovered to contain a use-after-free vulnerability in torch/csrc/jit/mobile/interpreter.cpp.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pytorch use-after-free vulnerability","id":"CVE-2024-31583","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"use_after_free","year":"2024"},"n_packages":4,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2024-31584"},"packages":[{"ecosystem":"Bitnami","fixed":["2.2.1"],"introduced":["0"],"last_affected":[],"package":"pytorch","purl":"pkg:bitnami/pytorch","source":"BIT-pytorch-2024-31583"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"torch","purl":null,"source":"GHSA-pg7h-5qx3-wjr3"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"torch","purl":"pkg:pypi/torch","source":"GHSA-pg7h-5qx3-wjr3"},{"ecosystem":"PyPI","fixed":["2.2.0"],"introduced":["0"],"last_affected":[],"package":"torch","purl":"pkg:pypi/torch","source":"PYSEC-2024-251"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2024-31582"},"products":["n/a"],"published":"2024-04-17","related":[{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2024-48063","kev_date_added":null,"published":"2024-10-29"},{"cvss_score":9.8,"headline":"PyTorch vulnerable to arbitrary code execution","id":"CVE-2022-45907","kev_date_added":null,"published":"2022-11-26"},{"cvss_score":9.3,"headline":"PyTorch: `torch.load` with `weights_only=True` leads to remote code execution","id":"CVE-2025-32434","kev_date_added":null,"published":"2025-04-18"},{"cvss_score":8.8,"headline":"PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files","id":"CVE-2026-24747","kev_date_added":null,"published":"2026-01-27"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2025-55551","kev_date_added":null,"published":"2025-09-25"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2025-55553","kev_date_added":null,"published":"2025-09-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"A use-after-free flaw in PyTorch's mobile interpreter allows attackers to potentially execute arbitrary code or cause a denial of service.","url":"https://insights.sbomify.com/CVE-2024-31583/"}