# CVE-2024-31584: Memory corruption in n/a

> An out-of-bounds read in PyTorch's mobile flatbuffer loader allows attackers to read memory or cause a crash.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** AZL-40043, BIT-pytorch-2024-31584, DEBIAN-CVE-2024-31584, GHSA-vmg3-jxcp-7rqw, PYSEC-2024-250, UBUNTU-CVE-2024-31584

## What is CVE-2024-31584?

CVE-2024-31584 is a medium-severity memory corruption vulnerability in n/a, published on 19 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Pytorch before v2.2.0 has an Out-of-bounds Read vulnerability via the component torch/csrc/jit/mobile/flatbuffer_loader.cpp.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2024-31584?

2 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | All versions | 2.2.1 |
| `torch` | PyPI | All versions | 2.2.0 |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2024-31584?

Upgrade pytorch to 2.2.1 or later.

## Is CVE-2024-31584 being exploited?

There is no known exploitation of CVE-2024-31584 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2025-32434](https://insights.sbomify.com/CVE-2025-32434/): PyTorch: `torch.load` with `weights_only=True` leads to remote code execution (critical 9.3)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31584 and fix it if it is affected.

What it is: CVE-2024-31584 is a medium-severity memory corruption vulnerability in n/a, published on 19 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-31584 in the wild and no public exploit code.

Affected packages and fixed versions:
- pytorch (Bitnami): affected all versions; fixed in 2.2.1
- torch (PyPI): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31584/ (Markdown: https://insights.sbomify.com/CVE-2024-31584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31584
- OSV: https://osv.dev/vulnerability/CVE-2024-31584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31584/
Summaries are generated and may contain mistakes; the official description above is the record.
