{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31621 exists.","fix":"Upgrade flowise to 1.8.1 or later.","what":"CVE-2024-31621 is a high-severity code injection vulnerability in Flowiseai Flowise, published on 29 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-31621 and fix it if it is affected.\n\nWhat it is: CVE-2024-31621 is a high-severity code injection vulnerability in Flowiseai Flowise, published on 29 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31621 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 1.8.1\n- flowise (npm): affected all versions; fixed in 1.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-31621/ (Markdown: https://insights.sbomify.com/CVE-2024-31621/index.md)","id":"CVE-2024-31621","markdown":"https://insights.sbomify.com/CVE-2024-31621/index.md","name":"CVE-2024-31621","record":{"aliases":["GHSA-6wp6-22x5-rr3w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise AI platform","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code in Flowise via crafted scripts, requiring immediate upgrades to secure the application.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":7.6,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"An issue in FlowiseAI Inc Flowise v.1.6.2 and before allows a remote attacker to execute arbitrary code via a crafted script to the api/v1 component.","ecosystems":["npm"],"exploits":{"exploitdb":1,"first_seen":"2024-04-21","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":"2024-04-21","kind":"exploitdb","ref":"52001","stars":null,"title":"Flowise 1.6.5 - Authentication Bypass"},{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-31621.yaml","stars":null,"title":"Flowise 1.6.5 - Authentication Bypass"}],"tier":"weaponised"},"has_fix":true,"headline":"Flowise vulnerable to code injection via api/v1","id":"CVE-2024-31621","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2024-31622"},"packages":[{"ecosystem":"npm","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-6wp6-22x5-rr3w"},{"ecosystem":"npm","fixed":["1.8.1"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-6wp6-22x5-rr3w"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2024-31617"},"products":["n/a"],"published":"2024-04-29","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code in Flowise via crafted scripts, requiring immediate upgrades to secure the application.","url":"https://insights.sbomify.com/CVE-2024-31621/"}