# CVE-2024-31621: Flowise vulnerable to code injection via api/v1

> Remote attackers can execute arbitrary code in Flowise via crafted scripts, requiring immediate upgrades to secure the application.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-6wp6-22x5-rr3w

## What is CVE-2024-31621?

CVE-2024-31621 is a high-severity code injection vulnerability in Flowiseai Flowise, published on 29 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue in FlowiseAI Inc Flowise v.1.6.2 and before allows a remote attacker to execute arbitrary code via a crafted script to the api/v1 component.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-31621?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 1.8.1 |
| `flowise` | npm | All versions | 1.8.1 |

Products: Flowiseai Flowise.

## How do I fix CVE-2024-31621?

Upgrade flowise to 1.8.1 or later.

## Is CVE-2024-31621 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31621 exists.

Public exploit code:

- Flowise 1.6.5 - Authentication Bypass (exploitdb)
- Flowise 1.6.5 - Authentication Bypass (nuclei): http/cves/2024/CVE-2024-31621.yaml

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-31621 and fix it if it is affected.

What it is: CVE-2024-31621 is a high-severity code injection vulnerability in Flowiseai Flowise, published on 29 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-31621 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 1.8.1
- flowise (npm): affected all versions; fixed in 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-31621/ (Markdown: https://insights.sbomify.com/CVE-2024-31621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-31621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-31621
- OSV: https://osv.dev/vulnerability/CVE-2024-31621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-31621/
Summaries are generated and may contain mistakes; the official description above is the record.
