CVE-2024-3178 Concrete CMS Cross-site Scripting (XSS) in the Advanced File Search Filter
A rogue administrator can inject malicious scripts via the Advanced File Search Filter, potentially compromising other users' sessions or data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-3178?
CVE-2024-3178 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 3 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Concrete CMS versions 9 below 9.2.8 and versions below 8.5.16 are vulnerable to Cross-site Scripting (XSS) in the Advanced File Search Filter. Prior to the fix, a rogue administrator could add malicious code in the file manager because of insufficient validation of administrator provided data. All administrators have access to the File Manager and hence could create a search filter with the malicious code attached. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator .
Weakness: CWE-79
Which versions are affected by CVE-2024-3178?
4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
concrete5/concrete5 Packagist | All versions | 8.5.16 |
concrete5/concrete5 Packagist | All versions | 8.5.16 |
concrete5/concrete5 Packagist | From 9.0.0RC1 | 9.2.8 |
concrete5/concrete5 Packagist | From 9.0.0RC1 | 9.2.8 |
Products include Concretecms Concrete Cms.
How do I fix CVE-2024-3178?
Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.16 or 9.2.8.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-3178 being exploited?
There is no known exploitation of CVE-2024-3178 in the wild and no public exploit code.
Other vulnerabilities in Concretecms Concrete Cms
- CVE-2023-48648 Concrete CMS allows unauthorized access because directories can be created with insecure permissions
- CVE-2022-21829 Code injection in concrete CMS
- CVE-2021-22958 Server-Side Request Forgery vulnerability in concrete5
- CVE-2021-40098 Path traversal in n/a
- CVE-2026-8134 Concrete CMS Vulnerable to Relative Path Traversal
Sources
Also known as GHSA-xwrh-qxmc-x8c8.