# CVE-2024-3178: Concrete CMS Cross-site Scripting (XSS) in the Advanced File Search Filter

> A rogue administrator can inject malicious scripts via the Advanced File Search Filter, potentially compromising other users' sessions or data.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2024
- **Updated:** 30 Aug 2024
- **Also known as:** GHSA-xwrh-qxmc-x8c8

## What is CVE-2024-3178?

CVE-2024-3178 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 3 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Concrete CMS versions 9 below 9.2.8 and versions below 8.5.16 are vulnerable to Cross-site Scripting (XSS) in the Advanced File Search Filter. Prior to the fix, a rogue administrator could add malicious code in the file manager because of insufficient validation of administrator provided data. All administrators have access to the File Manager and hence could create a search filter with the malicious code attached. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of  AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator .

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-3178?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 8.5.16 |
| `concrete5/concrete5` | Packagist | All versions | 8.5.16 |
| `concrete5/concrete5` | Packagist | From 9.0.0RC1 | 9.2.8 |
| `concrete5/concrete5` | Packagist | From 9.0.0RC1 | 9.2.8 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2024-3178?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.16 or 9.2.8.

## Is CVE-2024-3178 being exploited?

There is no known exploitation of CVE-2024-3178 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3178 and fix it if it is affected.

What it is: CVE-2024-3178 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 3 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-3178 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.16
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.16
- concrete5/concrete5 (Packagist): affected from 9.0.0RC1; fixed in 9.2.8
- concrete5/concrete5 (Packagist): affected from 9.0.0RC1; fixed in 9.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3178/ (Markdown: https://insights.sbomify.com/CVE-2024-3178/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3178
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3178
- OSV: https://osv.dev/vulnerability/CVE-2024-3178

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3178/
Summaries are generated and may contain mistakes; the official description above is the record.
