CVE-2024-3179 Concrete CMS Stored XSS in the Custom Class page editing

Low 3.1 Published Updated

A rogue administrator can inject malicious scripts into the Custom Class page, leading to stored XSS attacks against other users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-3179?

CVE-2024-3179 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 3 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Concrete CMS version 9 before 9.2.8 and previous versions before 8.5.16 are vulnerable to Stored XSS in the Custom Class page editing. Prior to the fix, a rogue administrator could insert malicious code in the custom class field due to insufficient validation of administrator provided data. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Thanks Alexey Solovyev for reporting.

Weakness: CWE-79

Which versions are affected by CVE-2024-3179?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.16
concrete5/concrete5 PackagistAll versions8.5.16
concrete5/concrete5 PackagistFrom 9.0.0RC19.2.8
concrete5/concrete5 PackagistFrom 9.0.0RC19.2.8

Products include Concretecms Concrete Cms.

How do I fix CVE-2024-3179?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.16 or 9.2.8.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-3179 being exploited?

There is no known exploitation of CVE-2024-3179 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-r7q4-cw9r-vhp4.

Is CVE-2024-3179 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free