CVE-2024-3180 Concrete CMS Stored XSS in blocks of type file

Low 3.1 Published Updated

A rogue administrator can inject malicious scripts into file block link-text fields, leading to stored XSS attacks against other users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-3180?

CVE-2024-3180 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 3 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Concrete CMS version 9 below 9.2.8 and previous versions below 8.5.16 is vulnerable to Stored XSS in blocks of type file. Stored XSS could be caused by a rogue administrator adding malicious code to the link-text field when creating a block of type file. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Thanks Alexey Solovyev for reporting.

Weakness: CWE-79

Which versions are affected by CVE-2024-3180?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.16
concrete5/concrete5 PackagistAll versions8.5.16
concrete5/concrete5 PackagistFrom 9.0.0RC19.2.8
concrete5/concrete5 PackagistFrom 9.0.0RC19.2.8

Products include Concretecms Concrete Cms.

How do I fix CVE-2024-3180?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.16 or 9.2.8.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-3180 being exploited?

There is no known exploitation of CVE-2024-3180 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-9qhc-pg6j-wf23.

Is CVE-2024-3180 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free