CVE-2024-3181 Concrete CMS Stored XSS in the Search Field

Low 3.1 Published Updated

An administrator can inject malicious scripts into the search field, leading to stored XSS attacks against other users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-3181?

CVE-2024-3181 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 3 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Concrete CMS version 9 prior to 9.2.8 and previous versions prior to 8.5.16 are vulnerable to Stored XSS in the Search Field. Prior to the fix, stored XSS could be executed by an administrator changing a filter to which a rogue administrator had previously added malicious code. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Thanks Alexey Solovyev for reporting

Weakness: CWE-79

Which versions are affected by CVE-2024-3181?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions8.5.16
concrete5/concrete5 PackagistAll versions8.5.16
concrete5/concrete5 PackagistFrom 9.0.0RC19.2.8
concrete5/concrete5 PackagistFrom 9.0.0RC19.2.8

Products include Concretecms Concrete Cms.

How do I fix CVE-2024-3181?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.16 or 9.2.8.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-3181 being exploited?

There is no known exploitation of CVE-2024-3181 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-qgm9-rxmq-jxmq.

Is CVE-2024-3181 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free